chore(deps): update dependency eslint-config-prettier to v9

Renovate-Bot requested to merge renovate/eslint-config-prettier-9.x into dev

This MR contains the following updates:

Package Type Update Change
eslint-config-prettier devDependencies major ^6.15.0 -> ^9.0.0

Release Notes

prettier/eslint-config-prettier

v9.1.0

Compare Source

  • Added: [unicorn/template-indent], (as a [special rule][unicorn/template-indent-special]). Thanks to Gürgün Dayıoğlu (@​gurgunday)!
  • Changed: All the [formatting rules that were deprecated in ESLint 8.53.0][deprecated-8.53.0] are now excluded if you set the ESLINT_CONFIG_MRETTIER_NO_DEMRECATED environment variable.

v9.0.0

Compare Source

  • Added: The CLI helper tool now works with eslint.config.js (flat config). Just like ESLint itself, the CLI tool automatically first tries eslint.config.js and then eslintrc, and you can force which one to use by setting the [ESLINT_USE_FLAT_CONFIG] environment variable. Note that the config of eslint-config-prettier has always been compatible with eslint.config.js (flat config) – it was just the CLI tool that needed updating. On top of that, the docs have been updated to mention how to use both eslint.config.js (flat config) and eslintrc, and the tests now test both config systems.
  • Changed: [unicode-bom] is no longer turned off. Prettier preserves the BOM if you have one, and does not add one if missing. It was wrong of eslint-config-prettier to disable that rule. If you get ESLint errors after upgrading, either add "unicode-bom": "off" to your config to disable it again, or run ESLint with --fix to fix all files according to the rule (add or remove BOM). Thanks to Nicolas Stepien (@​nstepien)!

v8.10.0

Compare Source

  • Added: [max-statements-per-line]. Thanks to @​Zamiell!

v8.9.0

Compare Source

  • Added: [vue/array-element-newline]. Thanks to @​xcatliu!

v8.8.0

Compare Source

v8.7.0

Compare Source

v8.6.0

Compare Source

  • Added: [vue/multiline-ternary]. Thanks to @​xcatliu!

v8.5.0

Compare Source

v8.4.0

Compare Source

v8.3.0

Compare Source

v8.2.0

Compare Source

  • Added: [flowtype/quotes]. Thanks to Martin Zlámal (@​mrtnzlml)!

v8.1.0

Compare Source

  • Added: [flowtype/object-type-curly-spacing].
  • Added: Dummy files for the configs removed in 8.0.0. The dummy files throw an error that try to guide you how to upgrade.

v8.0.0

Compare Source

  • Changed: All configs have been merged into one!

    To upgrade, change:

    {
      "extends": [
        "some-other-config-you-use",
        "prettier",
        "prettier/@​typescript-eslint",
        "prettier/babel",
        "prettier/flowtype",
        "prettier/react",
        "prettier/standard",
        "prettier/unicorn",
        "prettier/vue"
      ]
    }

    Into:

    {
      "extends": [
        "some-other-config-you-use",
        "prettier"
      ]
    }

    The "prettier" config now includes not just ESLint core rules, but also rules from all plugins. Much simpler!

    So … what’s the catch? Why haven’t we done this earlier? Turns out it’s just a sad mistake. I (@​lydell) was confused when testing, and thought that turning off unknown rules in a config was an error. Thanks to Georgii Dolzhykov (@​thorn0) for pointing this out!

    If you use [eslint-plugin-prettier], all you need is [plugin:prettier/recommended]:

    {
      "extends": [
        "some-other-config-you-use",
        "plugin:prettier/recommended"
      ]
    }

    (The ["prettier/prettier" config][prettier-prettier-config] still exists separately. It’s the odd one out. The main "prettier" config does not include the rules from it.)

  • Changed: The CLI helper tool now only prints warnings for [arrow-body-style] and [prefer-arrow-callback], just like other “special rules.” This means that if you’ve decided to use those rules and [eslint-plugin-prettier] at the same time, you’ll get warnings but exit code zero (success).

v7.2.0

Compare Source

v7.1.0

Compare Source

  • Added: [unicorn/empty-brace-spaces]. Thanks to fisker Cheung (@​fisker)!

v7.0.0

Compare Source

  • Changed: At least ESLint 7.0.0 is now required.

  • Changed: [arrow-body-style] and [prefer-arrow-callback] are no longer turned off by default. They only need to be turned off if you use [eslint-plugin-prettier]. If you do, add "prettier/prettier" to your "extends" array to turn them off again.

    {
      "extends": ["prettier", "prettier/prettier"],
      "plugins": ["prettier"],
      "rules": {
        "prettier/prettier": "error"
      }
    }

    Alternatively, update [eslint-plugin-prettier] to version 3.2.0 or later which automatically turns off these two rules in its "plugin:prettier/recommended" config.

    The CLI helper tool only warns about these rules if you have the "prettier/prettier" rule enabled for a file.

  • Changed: no-tabs is now a validatable rule. If you use it, you should enable allowIndentationTabs so that the rule works regardless of your Prettier config:

    {
      "rules": {
        "no-tabs": ["error", { "allowIndentationTabs": true }]
      }
    }
  • Changed: The CLI helper tool is now called just eslint-config-prettier instead of eslint-config-prettier-check. This is so that npx eslint-config-prettier always works regardless of whether you have already installed eslint-config-prettier or not: If you have, the local installation is used; if you haven’t, npx downloads a temporary copy.

  • Changed: The CLI helper tool no longer requires you to pipe the output of eslint --print-config to it. Instead, it does that automatically for you via ESLint API:s added in ESLint v7.

    Before:

    npx eslint --print-config index.js | npx eslint-config-prettier-check

    After:

    npx eslint-config-prettier index.js
  • Improved: The npm package is now 75% smaller.


Configuration

📅 Schedule: At any time (no schedule defined).

🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.

Rebasing: Whenever MR is behind base branch, or you tick the rebase/retry checkbox.

🔕 Ignore: Close this MR and you won't be reminded about this update again.


  • If you want to rebase/retry this MR, click this checkbox.

This MR has been generated by Renovate Bot.

Edited by Renovate-Bot

Merge request reports